Terran Legacy Forum

Armor Locker glitch?? 5 replies

Lemon_X said on: 2009-06-01 10:07 pm
3401 Days, 10 Hrs, 21 Min, 31 Sec ago
Hi,

I haven't been playing this for very long and I was wondering if this is a glitch or just a one time thing.

I've been looking for the Forbidden Armor Locker forever it seems. Finally I'd found it. Awesome! Maybe not so much it turns out. I successfully sold my current armor and tried to buy the siege tank armor. When I clicked the link to buy it, the anti-bot page was displayed. I then found myself outside of the armor locker without my new armor :( lol Of course I didn't have my old armor either. I didn't lose any credits except what I lost for selling the old one and having to re-buy it. Not a big loss, but now I have to go searching again. Oh well. Like I said, just wondering if it's happened to anyone else.

Cheers
Jing said on: 2009-06-02 04:02 am
3401 Days, 4 Hrs, 26 Min, 54 Sec ago
Probably.
I think it's just bad luck lol.
IconStealerX said on: 2009-06-02 06:33 pm
3400 Days, 13 Hrs, 55 Min, 20 Sec ago
Oo0Oo0

Lemons!!! :O
Crowther said on: 2009-06-03 12:49 pm
3399 Days, 19 Hrs, 39 Min, 27 Sec ago
You just have bad luck.

But it has happened to me but with a item I tryed to pick it up and i got the anti-bot so i didn't get my shield generator.
ShadyKnight (Mod) said on: 2009-06-03 05:21 pm
3399 Days, 15 Hrs, 7 Min, 24 Sec ago
The odds of that happening are slim, but it does happen. It's happened to me on several occasions. Really crappy...
ShadowLord69 said on: 2009-06-09 06:27 am
3394 Days, 2 Hrs, 1 Min, 32 Sec ago
This one time at band camp, Ashley played with a flute!

True Story!